protege导入eclipse中报错的解决方法

将protege的源码导入到eclipse中本应该是比较简单的事情,在eclipse里面装好maven插件,然后编译就可以了。但是昨天女票在导入的时候一直报错。报错
提示将jre换到1.5或更高的版本,但是电脑里面装的是1.8的java,尝试过重新下载maven依赖包、重新导入项目,结果都不能解决问题。后来怀疑应该是eclipse的问题。因为我用的是neon版本的eclipse,一切正常,女票用的是kehper版本的eclipse。
项目导入到eclipse中之后,jre使用的版本就变成了1.4。
报错
最后去百度了一下,发现kehper版本以前的eclipse并不支持java1.8,因此按照这篇博客中的方法安装好了插件之后,eclipse就可以完美的支持java1.8了。之后在项目的JRE System Library上右键,选择属性,选择使用1.8版本进行编译,问题就完美的解决了。
经验:IDE如果能用新的版本,尽可能选择较新的,原因有三点:

  • 因为可能会对bug进行改进。
  • 会支持新的特性。
  • 使用起来会更加方便。

本文作者:Qiu Qingyu
版权声明:本博客所有文章除特别声明外,均采用CC BY-NC-SA 3.0 CN许可协议。转载请注明出处!
本文永久链接:http://qiuqingyu.cn/2017/04/01/protege导入eclipse中报错的解决方法/